您的位置:首页 > 其它

POJ1836 双向LIS

2015-11-27 17:05 267 查看
一开始没怎么看题意,以为是要问去掉几个人能使队列由矮到高排好,看了看样例好像还真是,就直接敲了一发LIS上去,结果WA了..然后再仔细看看题目…是要求每一个士兵都能看到队列中最高和最矮那个士兵,就是队列要呈一个三角形,中间高,两边矮,所以从头和从尾开始都来一遍LIS,然后处理下就好了

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , … , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line’s extremity (left or right). A soldier see an extremity if there isn’t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:

• 2 <= n <= 1000

• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8

1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

double a[1005];
int b[1005],c[1005];

int main()
{
int n;
while (scanf("%d",&n)!=EOF)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for (int i = 0;i<n;i++)
scanf("%lf",&a[i]);
b[0] = 1;
for (int i = 0;i<n;i++)
{
b[i] = 1;
for (int j = 0;j<i;j++)
{
if (a[i] > a[j] && b[j]+1 > b[i])
b[i] = b[j] + 1;
}
}

c[n-1] = 1;
for (int i = n-1;i>=0;i--)
{
c[i] = 1;
for (int j = n-1;j>=i;j--)
{
if (a[i] > a[j] && c[j]+1 > c[i])
c[i] = c[j] + 1;
}
}
int maxn = 0;
for (int i = 0;i<n;i++)
for (int j = i+1;j<n;j++)
maxn = max(maxn,b[i]+c[j]);
printf("%d\n",n-maxn);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: