您的位置:首页 > 其它

1058. A+B in Hogwarts (20)

2015-11-27 13:54 351 查看
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:

14.1.28

--------------------华丽的分割线-----------------------

代码:

#include<cstdio>
#include<cstdlib>

int inputA[3];
int inputB[3];
int output[3];

int main(void)
{
scanf("%d.%d.%d",inputA,inputA+1,inputA+2);
scanf("%d.%d.%d",inputB,inputB+1,inputB+2);
int i;
for(i=0;i<3;++i)
{
output[i] = inputA[i] + inputB[i];
}
if(output[2] > 28)
{
output[1] += output[2] / 29;
output[2] %= 29;
}
if(output[1] > 16)
{
output[0] += output[1] / 17;
output[1] %= 17;
}
for(i=0;i<3;++i)
{
printf("%d",output[i]);
if(i!=2)
printf(".");
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: