您的位置:首页 > 其它

1054. The Dominant Color (20)

2015-11-27 13:52 435 查看
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more
than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224).
It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:
24

-----------------华丽的分割线------------------------
分析:对每一个输入进行存取,当发现超过半数时就可以break出去了。
代码:
#include<cstdio>
#include<cstdlib>

#define Maxn 20000000

int countmax[Maxn];

int main(void)
{
int M,N;
scanf("%d %d",&M,&N);
int total = M*N;
int mid = total/2;
int input,max;
for(int i=0;i<total;++i)
{
scanf("%d",&input);
if(++countmax[input] > mid)
{
max = input;
}
}
printf("%d",max);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: