您的位置:首页 > 其它

杭电oj 1005

2015-11-26 20:46 399 查看
先看题目

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 136694 Accepted Submission(s): 33137



[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0


[align=left]Sample Output[/align]

2
5


暴力计算肯定是会超时的,考虑到mod7运算肯定是会有循环的,循环结束的条件就是找到连续的两个数mod7相等,举个例子
若 f(a)%7=1,f(a+1)%7=2; f(b)%7=1,f(b+1)%7=2;则循环的长度就是b-a,相信大家都能理解这个道理
但是有一点是它可能循环的时候并不是以f(1)开始的,所以我们不能以f(1)%7=1,f(2)%7=1来找循环结束条件
我得代码如下,
#include <iostream>
using namespace std;
int turn[1000];
int main()
{
int A,B,number;
int count;
int i;
bool flag;
int start;
cin>>A>>B>>number;
turn[0]=1;
turn[1]=1;
while(A!=0||B!=0||number!=0)
{
count=3;
turn[2]=(A*turn[1]+B*turn[0])%7;
flag=false;
while(1)
{
turn[count]=(A*turn[count-1]+B*turn[count-2])%7;
for(i=0;i<count-2;i++)
{
if(turn[count-1]==turn[i]&&turn[count]==turn[i+1])
{
count=count-i;
start=i;
flag=true;
break;
}
}
if(flag==true)
break;
count++;
}
if(number>start)
cout<<turn[(number-start-1)%(count-1)+start]<<endl;
else
cout<<turn[number]<<endl;

cin>>A>>B>>number;
}
return 0;
}
ac了


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: