您的位置:首页 > 其它

Least Common Multiple最小公倍数 17

2015-11-25 20:25 232 查看
Least Common Multiple最小公倍数
Problem Description
The least common multiple (LCM) of a set of positiveintegers is the smallest positive integer which is divisible by all the numbersin the set. For example, the LCM of 5, 7 and 15 is 105.
一组正整数的最小公倍数(LCM)的最小正整数整除在该组的所有数字。例如,第五,第七和15的LCM是105。

Input
Input will consistof multiple problem instances. The first line of the input will contain asingle integer indicating the number of problem instances. Each instance willconsist of a single line of the form m n1 n2 n3 ... nm where m is the number
ofintegers in the set and n1 ... nm are the integers. All integers will bepositive and lie within the range of a 32-bit integer.
输入将包含多个问题的实例。输入的第一行包含一个单一的整数,表示问题的实例的数量。每个实例将包括形式米单行N1 N2 N3... nm其中,m是在该组和N1 ......纳米整数的数目是整数。所有整数将为正和位于32位整数的范围内。
Output
For each probleminstance, output a single line containing the corresponding LCM. All resultswill lie in the range of a 32-bit integer.
对于每个问题的实例,包含输出一行相应的LCM。所有结果将位于32位整数的范围
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296
代码如下:

#include <stdio.h>
#include <stdlib.h>
int gcd(int a,int b)
{
    if(b==0)
	return a;
    return gcd(b,a%b);
}    
int main()
{
    int group;
    int n,a,b,i;
    int cnt;
    scanf("%u",&group);
    while(group--)
    {
        scanf("%d",&n);
        cnt=a=1;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&b);
            cnt=a/gcd(a,b)*b;//换一下,先除后乘,免得数据溢出 
            a=cnt;
        } 
        printf("%d\n",cnt);   
    }    
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: