您的位置:首页 > 其它

hdu 2058 The sum problem

2015-11-25 17:17 302 查看

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19608 Accepted Submission(s): 5786


[align=left]Problem Description[/align]
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

[align=left]Input[/align]
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

[align=left]Output[/align]
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

[align=left]Sample Input[/align]

20 10

50 30
0 0

[align=left]Sample Output[/align]

[1,4]
[10,10]

[4,8]

[6,9]
[9,11]

[30,30]

[align=left]Author[/align]
8600
题意:给两个值n,m,表示一个长度为n的数列,让你从这个数列中找出所有连续的子序列使他们的和为m

题解:见我这篇博客

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MAX 1001000
using namespace std;
struct node
{
int a,b;
}s[MAX];
bool cmp(node x,node y)
{
return x.a<y.a;
}
int main()
{
int n,m,j,i,t,k;
t=0;
while(scanf("%d%d",&n,&m),n|m)
{
int ans=sqrt(2*n);
int x;k=0;
for(i=1;i<=ans;i++)
{
x=(2*m+i-i*i)/2/i;
if((2*x+i-1)*i==2*m&&x>0&&(i%2==0||(2*x+i-1)%2==0))
{
s[k].a=x;
s[k++].b=x+(i-1);
}
}
sort(s,s+k,cmp);
for(i=0;i<k;i++)
printf("[%d,%d]\n",s[i].a,s[i].b);
t++;
printf("\n");
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: