您的位置:首页 > 其它

poj1847Tram【floyd】

2015-11-25 13:29 344 查看
Language:
Default

Tram

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12489 Accepted: 4557
Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in
the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections
directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".
Sample Input
3 2 1
2 2 3
2 3 1
2 1 2

Sample Output
0


题意:给出一些十字路口通过这些十字路口可到达下一个十字路口给出一个十字路口和它能到达的十字路口第一个不需要转换其余的需要花一次进行转换求从a到b所需的最小转换次数

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=110;
int map[maxn][maxn];
void floyd(int n){
for(int k=1;k<=n;++k){
for(int i=1;i<=n;++i){
for(int j=1;j<=n;++j){
map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
}
}
}
}
int main()
{
int a,b,n,i,j,k,m;
while(scanf("%d%d%d",&n,&a,&b)!=EOF){
memset(map,0x3f,sizeof(map));
for(int i=1;i<=n;++i){
scanf("%d",&k);
int falg=1;
while(k--){
scanf("%d",&m);
if(falg)map[i][m]=0;
else map[i][m]=1;
falg=0;
}
}
floyd(n);
if(map[a][b]<inf){
printf("%d\n",map[a][b]);
}
else {
printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj1847Tramfloyd