您的位置:首页 > 其它

hdu3579(线性同余方程组)

2015-11-24 23:18 246 查看

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2734 Accepted Submission(s): 1010


[align=left]Problem Description[/align]
One
day I was shopping in the supermarket. There was a cashier counting
coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来
数一数,二四六七八". And then the cashier put the counted coins back morosely and
count again...
Hello Kiki is such a lovely girl that she loves doing
counting in a different way. For example, when she is counting X coins,
she count them N times. Each time she divide the coins into several
same sized groups and write down the group size Mi and the number of the
remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

[align=left]Input[/align]
The first line is T indicating the number of test cases.
Each
case contains N on the first line, Mi(1 <= i <= N) on the second
line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

[align=left]Output[/align]
For
each case output the least positive integer X which Kiki was counting
in the sample output format. If there is no solution then output -1.

[align=left]Sample Input[/align]

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

[align=left]Sample Output[/align]

Case 1: 341
Case 2: 5996

[align=left]Author[/align]
digiter (Special Thanks echo)

[align=left]Source[/align]
2010 ACM-ICPC Multi-University Training Contest(14)——Host by BJTU

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;

/*对于x=r0(mod m0)
x=r1(mod m1)
...
x=rn(mod mn)
输入数组m和数组r,返回[0,[m0,m1,...,mn]-1] 范围内满足以上等式的x0。
x的所有解为:x0+z*[m0,m1,...mn](z为整数)
*/
long long cal_axb(long long a,long long b,long long mod)
{
//防乘法溢出
long long sum=0;
while(b)
{
if(b&1) sum=(sum+a)%mod;
b>>=1;
a=(a+a)%mod;
}
return sum;
}

//ax + by = gcd(a,b)
//传入固定值a,b.放回 d=gcd(a,b), x , y
void extendgcd(long long a,long long b,long long &d,long long &x,long long &y)
{
if(b==0){d=a;x=1;y=0;return;}
extendgcd(b,a%b,d,y,x);
y -= x*(a/b);
}

long long Multi_ModX(long long m[],long long r[],int n,long long &M)
{
long long m0,r0;
m0=m[0]; r0=r[0];
for(int i=1;i<n;i++)
{
long long m1=m[i],r1=r[i];
long long k0,k1;
long long tmpd;
extendgcd(m0,m1,tmpd,k0,k1);
if( (r1 - r0)%tmpd!=0 ) return -1;
k0 *= (r1-r0)/tmpd;
m1 *= m0/tmpd;
r0 = ( cal_axb(k0,m0,m1)+r0)%m1;
m0=m1;
}
M=m0;
return (r0%m0+m0)%m0;
}

int main()
{
int T;
cin>>T;
int tt=1;
while(T--)
{
int n;
cin>>n;
long long a[10],b[10];
for(int i=0;i<n;i++)
cin>>a[i];
for(int i=0;i<n;i++)
cin>>b[i];
long long M;
long long ans=Multi_ModX(a,b,n,M);
printf("Case %d: ",tt++);
if(ans==0) ans+=M;
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: