您的位置:首页 > 其它

poj Find them, Catch them 1703 (并查集推广)

2015-11-24 21:09 447 查看
Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37694 Accepted: 11627
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to.
The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message
as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

//题意:

有n个人,还有m个条件,若条件是D,表示x,y不是一个阵营,若条件为A,表示提问x,y是否在一个阵营。

#include<stdio.h>
#include<string.h>
#define N 100010
int rank
;
int a
;
int find(int x)
{
if(x==a[x])
return x;
else
{
int tmp=a[x];
a[x]=find(a[x]);
rank[x]=(rank[x]+rank[tmp])%2;
return a[x];
}
}
int main()
{
int t,n,m;
char c;
int x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
a[i]=i;
memset(rank,0,sizeof(rank));
while(m--)
{
getchar();
scanf("%c%d%d",&c,&x,&y);
int fx=find(x);
int fy=find(y);
if(c=='D')
{
a[fy]=fx;
rank[fy]=(rank[x]-rank[y]+1)%2;
continue;
}
else
{
if(fx!=fy)
printf("Not sure yet.\n");
else if(rank[x]!=rank[y])
printf("In different gangs.\n");
else if(rank[x]==rank[y])
printf("In the same gang.\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: