您的位置:首页 > 其它

POJ 2155 Matrix 【树状数组 更新区间 求点】

2015-11-24 15:26 441 查看

Matrix

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 22105Accepted: 8243
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

2. Q x y (1 <= x, y <= n) querys A[x, y].

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above.

Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output
1
0
0
1


恩,题目大意就是说,矩阵开始时全为零,然后 C x1 y1 x2 y2 表示以 x1 y1 和 x2 y2 为对角的矩形中的值都改变一次,若原为0改为1 若原为1改为0 。恩,至于修改时这里概率论里的某一点貌似有点相似,本来是从 x1 y1 到n n 的加1 然后从 x2+1 y1 到n n 的减1 由于这里只需判断奇偶数,所以减1相当于加1

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 1010
using namespace std;
int n,c[maxn][maxn];
int lowbit(int t)
{
return t&(t^(t-1));
}
void update(int x,int y)
{
for(int i=x;i<=n;i+=lowbit(i))
{
for(int j=y;j<=n;j+=lowbit(j))
c[i][j]++;
}
}
int sum(int x,int y)
{
int ans=0;
for(int i=x;i>0;i-=lowbit(i))
{
for(int j=y;j>0;j-=lowbit(j))
ans+=c[i][j];
}
return ans;
}
int main()
{
int t,q,x1,x2,y1,y2;
char s[5];
scanf("%d",&t);
while(t--)
{
memset(c,0,sizeof(c));
scanf("%d%d",&n,&q);
while(q--)
{
scanf("%s",s);
if(s[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
update(x1,y1);
update(x2+1,y1);
update(x1,y2+1);
update(x2+1,y2+1);
}
else
{
scanf("%d%d",&x1,&y1);
printf("%d\n",sum(x1,y1)%2);
}
}
printf("\n");
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: