您的位置:首页 > 其它

poj1734Sightseeing trip【floyd+最小环+路径记录】

2015-11-24 14:01 417 查看
Language:
Default

Sightseeing trip

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5771 Accepted: 2236 Special Judge
Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary
to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers
y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads
on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing
route in the town.
Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of
the second one, and the length of the road (a positive integer less than 500).
Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to
x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.
Sample Input
5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output
1 3 5 2


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 99999999
using namespace std;
const int maxn=110;
int path[maxn];
int map[maxn][maxn];
int dist[maxn][maxn];
int road[maxn][maxn];
int num;
void record(int s,int t){
if(road[s][t]){
record(s,road[s][t]);
record(road[s][t],t);
}
else path[num++]=t;
}
int floyd(int n){
memset(path,0,sizeof(path));
memset(road,0,sizeof(road));
int ans=inf;
for(int k=1;k<=n;++k){
for(int i=1;i<k;++i){
for(int j=i+1;j<k;++j){
if(ans>dist[i][j]+map[i][k]+map[k][j]){
ans=dist[i][j]+map[i][k]+map[k][j];
num=0;
path[num++]=i;
record(i,j);
path[num++]=k;
}
}
}
for(int i=1;i<=n;++i){
for(int j=1;j<=n;++j){
if(dist[i][j]>dist[i][k]+dist[k][j]){
dist[i][j]=dist[i][k]+dist[k][j];
road[i][j]=k;
}
}
}
}
return ans;
}
int main()
{
int i,j,n,m;
while(scanf("%d%d",&n,&m)!=EOF){
for(i=1;i<=n;++i){
for(j=1;j<=n;++j){
map[i][j]=dist[i][j]=inf;
}
}
int a,b,c;
for(i=0;i<m;++i){
scanf("%d%d%d",&a,&b,&c);
if(map[a][b]>c){
map[a][b]=map[b][a]=c;
dist[a][b]=dist[b][a]=c;
}
}
int ans=floyd(n);
if(ans<inf){
for(i=0;i<num;++i){
if(i){
printf(" %d",path[i]);
}
else {
printf("%d",path[i]);
}
}
printf("\n");
}
else {
printf("No solution.\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj1734Sightseeing t