您的位置:首页 > 其它

HDU 2586 最小公共祖先

2015-11-23 19:59 197 查看

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10005    Accepted Submission(s): 3565


[align=left]Problem Description[/align]
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this
village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

[align=left]Input[/align]
First line is a single integer T(T<=10), indicating the number of test cases.

  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road
connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.

  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

[align=left]Output[/align]
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

[align=left]Sample Input[/align]

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

 

[align=left]Sample Output[/align]

10
25
100
100 #include <iostream>
#include <string.h>
#include <stdio.h>
#include <vector>
using namespace std;
const int N = 50005;
vector<int> v
,w
,query
,num
;
int pre
,dist
,ans
;
bool vis
;
int n;
void Init()
{
    for(int i=1; i<=n; i++)
    {
        v[i].clear();
        w[i].clear();
        query[i].clear();
        num[i].clear();
        pre[i] = i;
        dist[i] = 0;
        vis[i] = false;
    }
}
int Find(int x)
{
    if(pre[x] != x)
        pre[x] = Find(pre[x]);
    return pre[x];
}
void Union(int x,int y)
{
    x = Find(x);
    y = Find(y);
    if(x == y) return;
    pre[y] = x;
}
void Tarjan(int cur,int val)
{
    vis[cur] = true;
    dist[cur] = val;
    int size = v[cur].size();
    for(int i=0;i<size;i++)
    {
        int tmp = v[cur][i];
        if(vis[tmp]) continue;
        Tarjan(tmp,val + w[cur][i]);
        Union(cur,tmp);
    }
    int Size = query[cur].size();
    for(int i=0;i<Size;i++)
    {
        int tmp = query[cur][i];
        if(!vis[tmp]) continue;
        ans[num[cur][i]] = dist[cur] + dist[tmp] - 2*dist[Find(tmp)];
    }
}
int main()
{
    int T,Q,x,y,z;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&Q);
        Init();
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            v[x].push_back(y);
            w[x].push_back(z);
            v[y].push_back(x);
            w[y].push_back(z);
        }
        for(int i=0;i<Q;i++)
        {
            scanf("%d%d",&x,&y);
            query[x].push_back(y);
            query[y].push_back(x);
            num[x].push_back(i);
            num[y].push_back(i);
        }
        Tarjan(1,0);
        for(int i=0;i<Q;i++)
           printf("%d\n",ans[i]);
    }
    return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: