您的位置:首页 > 其它

hdoj Co-prime 4135 (容斥原理)

2015-11-23 14:07 405 查看

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2778    Accepted Submission(s): 1070


[align=left]Problem Description[/align]
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.

Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

[align=left]Input[/align]
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).

[align=left]Output[/align]
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

[align=left]Sample Input[/align]

2
1 10 2
3 15 5

[align=left]Sample Output[/align]

Case #1: 5
Case #2: 10

HintIn the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.  思路:要求在l--r这一范围内与n互质的数的个数,先求出在此范围内不与n互质的数的个数num,然后用总个数减去num即为所求。应用容斥原理解。p数组用来存放n的因子,q数组用来存放各个因子的乘积。
#include<stdio.h>
#include<string.h>
#define ll long long
ll p[10010];
ll q[10010];
ll k;
void getp(ll n)
{
k=0;
ll i,j;
for(i=2;i*i<=n;i++)
{
if(n%i==0)
{
p[k++]=i;
while(n%i==0)
n/=i;
}
}
if(n>1)
p[k++]=n;
}
ll solve(ll n)
{
ll i,j,t=0,kk,sum=0;
q[t++]=-1;
for(i=0;i<k;i++)
{
kk=t;
for(j=0;j<kk;j++)
q[t++]=p[i]*q[j]*-1;
}
for(i=1;i<t;i++)
sum+=(n/q[i]);
return sum;
}
int main()
{
int t,T=1;
ll l,r,n;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld%lld",&l,&r,&n);
getp(n);
ll cnt=(r-solve(r))-(l-1-solve(l-1));
printf("Case #%d: %lld\n",T++,cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: