您的位置:首页 > 其它

hdu 1102 (最小生成树)

2015-11-23 11:05 405 查看


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18188 Accepted Submission(s): 6937



Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2


Sample Output

179
在建图的时候,把已经修好的路的距离设置为0(双向边),再进行prime就ac了。
#include"iostream"
#include"cstdio"
#include"cstring"
#include"string"
#include"algorithm"

#define MAXN 105
#define INF 0x7f7f7f7f

using namespace std;

int maze[MAXN][MAXN];
int dis[MAXN];
bool vis[MAXN];
int n, q, ans;

void init()
{
memset(maze, INF, sizeof(maze));
memset(dis, INF, sizeof(dis));
memset(vis, false, sizeof(vis));
ans =0;
}

void prim()
{
dis[1] =0;
for(int i=1; i<=n; i++)
{
int minn =INF;
int mark;
for(int j=1; j<=n; j++)
{
if(!vis[j] && dis[j]<minn)
{
minn = dis[j];
mark = j;
}
}
vis[mark] = true;
ans += dis[mark];
for(int j=1; j<=n; j++)
{
if(!vis[j] && dis[j]>maze[mark][j])
dis[j] = maze[mark][j];
}
}
printf("%d\n",ans);
}

int main(void)
{
while(~scanf("%d",&n))
{
init();
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
scanf("%d",&maze[i][j]);
}
scanf("%d",&q);
while(q--)
{
int x, y;
scanf("%d%d",&x,&y);
maze[x][y] =0;
maze[y][x] =0;
}
prim();
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: