您的位置:首页 > 其它

未AC

2015-11-22 21:02 330 查看
Count the Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1840    Accepted Submission(s): 1221

Problem Description

Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power
of the brain is applied to something extremely interesting or challenging. 

Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers,
and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements. 

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure. 

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful. 

 

Input

The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed. 

 

Output

For each input case print the number of binary trees that can be built using the n elements, followed by a newline character. 

 

Sample Input

1

2

10

25

0

 

Sample Output

1

4

60949324800

75414671852339208296275849248768000000

 

 

#include<iostream>

#include<cstdio>

#include<cstring>

#include<cmath>

using namespace std;

int h[102][1001];

int main()

{

   int n;

   h[1][0]=1;h[1][1]=1;

   h[2][0]=1;h[2][1]=1;

   for(int i=3;i<=100;i++)

   {

       int temp=0,jin=0;

       for(int j=1;j<=h[i-1][0];j++)

            {

                temp=h[i-1][j]*(4*i-2);

                h[i][j]=temp%10;

                h[i][j+1]=+temp/10;

            }

        int t=h[i-1][0];

       t=h[i][t+1]>0?t+1:t;

       while(h[i][t]>=10)

       {

            h[i][t+1]=h[i][t]/10;

            h[i][t]%=10;

            t++;

       }

       for(int j=t;j>=2;j--)

            {

                temp=h[i][j];

                h[i][j]=temp/(i+1);

                h[i][j-1]+=temp%(i+1)*10;

            }

   }

   for(int i=2;i<=100;i++)

   {

        for(int j=1;j<=i;j++)

              for(int k=1;k<=h[i][0];k++)

                    h[i][k]*=j;

         for(int t=1;t<=h[i][0];t++)

       {

             int temp=h[i][t];

             h[i][t]=temp%10;

             h[i][t+1]+=temp/10;

       }

        int t=h[i-1][0];

       while(h[i][t]>=10)

       {

            h[i][t+1]=h[i][t]/10;

            h[i][t]%=10;

            t++;

       }

        h[i][0]=t;

   }

   while(cin>>n&&n)

   {

         for(int i=h
[0];i>=1;i--)

            printf("%d",h
[i]);

         printf("\n");

   }

   return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: