您的位置:首页 > 其它

HDU1219-AC Me

2015-11-22 16:41 260 查看

Problem Description

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It's really easy, isn't it? So come on and AC ME.

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.

Output

For each article, you have to tell how many times each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.

Sample Input

hello, this is my first acm contest!
work hard for hdu acm.


Sample Output

a:1
b:0
c:2
d:0
e:2
f:1
g:0
h:2
i:3
j:0
k:0
l:2
m:2
n:1
o:2
p:0
q:0
r:1
s:4
t:4
u:0
v:0
w:0
x:0
y:1
z:0

a:2
b:0
c:1
d:2
e:0
f:1
g:0
h:2
i:0
j:0
k:1
l:0
m:1
n:0
o:2
p:0
q:0
r:3
s:0
t:0
u:1
v:0
w:1
x:0
y:0
z:0

水题,找到字符串中各个字母出现的次数,依次输出即可

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define maxn 100010
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
char str[maxn];
int num[26];
int main(int argc, char *argv[])
{
int i,t,l;

while(gets(str))
{
memset(num,0,sizeof(num));
l=strlen(str);
for(i=0;i<l;i++)
{
if(str[i]>='a'&&str[i]<='z')
{
t=str[i]-'a';
num[t]++;
}
}
for(i=0;i<26;i++)
{
printf("%c:%d\n",i+'a',num[i]);
}
printf("\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: