您的位置:首页 > 其它

hdoj 1051 Wooden Sticks(LIS变形)

2015-11-22 16:20 477 查看


Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15695    Accepted Submission(s): 6446


Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

Sample Output

2
1
3
dp和贪心都行! dp:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define  N  999999
struct node
{
int l;
int w;
}a
;
bool cmp(node  a,node  b)
{
if(a.l ==b.l )
return  a.w<b.w;
return  a.l <b.l;
}
int dp
;
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
int i,j,k,temp;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a[i].l ,&a[i].w );
dp[i]=1;
}
sort(a,a+n,cmp);
for(i=0;i<n;i++)
for(j=0;j<i;j++)
{
if(a[i].w<a[j].w&&dp[i]<dp[j]+1)
dp[i]=dp[j]+1;
}
int max=-1;
for(i=0;i<n;i++)
{
if(max<dp[i])
max=dp[i];
}
printf("%d\n",max);
}
return 0;
}

贪心:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define  N  999999
struct node
{
int l;
int w;
}a
;
bool cmp(node  a,node  b)
{
if(a.l ==b.l )
return  a.w<b.w;
return  a.l <b.l;
}
int dp
;
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
int i,j,k,temp;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a[i].l ,&a[i].w );
}
sort(a,a+n,cmp);
int time=0;
for(i=0;i<n;i++)
{
if(a[i].w !=0)
temp=a[i].w ;
else
continue;
for(j=i+1;j<n;j++)
{
if(temp<=a[j].w&&a[j].w !=0)
{
temp=a[j].w ;
a[j].w =0;
}
}
a[i].w =0;
time++;
}
printf("%d\n",time );
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息