您的位置:首页 > 产品设计 > UI/UE

BestCoder Round #63 (div.2) HDOJ5567 sequence1(暴力)

2015-11-22 11:11 786 查看


sequence1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 132    Accepted Submission(s): 103


Problem Description

Given an array a with
length n,
could you tell me how many pairs (i,j) (
i < j ) for abs(ai−aj) mod b=c.

 

Input

Several test cases(about 5)

For each cases, first come 3 integers, n,b,c(1≤n≤100,0≤c<b≤109)

Then follows n integers ai(0≤ai≤109)

 

Output

For each cases, please output an integer in a line as the answer.

 

Sample Input

3 3 2
1 2 3
3 3 1
1 2 3

 

Sample Output

1
2

 

题目链接:点击打开链接

注意到数据范围, 直接暴力计算即可.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cmath"
#include "utility"
#include "map"
#include "set"
#include "vector"
#include "list"
using namespace std;
typedef long long ll;
const int MOD = 1e9 + 7;
const int MAXN = 105;
int n, b, c, a[MAXN];
int main(int argc, char const *argv[])
{
while(scanf("%d%d%d", &n, &b, &c) != EOF) {
int ans = 0;
for(int i = 0; i < n; ++i)
scanf("%d", &a[i]);
for(int i = 0; i < n - 1; ++i)
for(int j = i + 1; j < n; ++j)
if(abs(a[i] - a[j]) % b == c) ans++;
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: