您的位置:首页 > 其它

hdoj ZZY’s Dilemma 4152 (DP) 好题

2015-11-20 21:39 232 查看

ZZY’s Dilemma

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 612    Accepted Submission(s): 258


[align=left]Problem Description[/align]
ZZY has many habits like seeing movie, listening music, playing PC game and football and so on. Besides he has many goals, as not every habit is good for achieving his goals, he falls into the dilemma of making a choice between his
goals and habits.

Now ,we define the effect that one habit has on each goal is represented as a vector,and the elements of the vector are integers,ex.vector(100,90,-10,80)means it has 100 point effect on goal 1,90 point effect on goal 2,-10 point effect on goal 3 and 80 point
effect on goal 4(the positive point means good effect and the negative point means bad effect),and the given requirement of each goal is represented as integer.please help ZZY to achieve his goals as well as keeps his habits as many as possible.

[align=left]Input[/align]
There are multi cases , read the data until EOF.( No more than 10 cases )

Line 1: The number of ZZY’s goals N(0<N<=20)

Line 2: The requirement of each goals (0 < w <= 1000)

Line 3: The number of ZZY’s habits M(0 < M <= 16)

Line 4-M+4: Each line contains N integers, the ith integer represents the effect on ith goal (-1000 <= data <= 1000).

[align=left]Output[/align]
For each case: The output is a single line that contains:

* the maximum number of habits ZZY can keep, followed by:

* a SORTED list (from smallest to largest) of the habit ZZY can keep. If more than one set of habits could meet the requirement, choose the set with the smallest habit numbers.

Just please output 0 if there is no way to achieve ZZY’s goals.

[align=left]Sample Input[/align]

4
100 200 300 400
3
100 100 400 500
100 -10 50 300
100 100 -50 -50

[align=left]Sample Output[/align]

2 1 3

#include<stdio.h>
#include<string.h>
int a[22];
int b[22][22];
int c[22];
int main()
{
int n,m,a1,a2;
int i,j,k;
while(scanf("%d",&n)!=EOF)
{
a1=-1;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
{
scanf("%d",&b[i][j]);
}
}
for(i=1;i<(1<<m);i++)
{
memset(c,0,sizeof(c));
int num=0;
for(j=0;j<m;j++)
{
if(i&(1<<j))
{
num++;
for(k=0;k<n;k++)
c[k]+=b[j][k];
}
}
int kk;
for(kk=0;kk<n;kk++)
if(c[kk]<a[kk])
break;
if(kk>=n)
{
if(num>a1)
{
a1=num;
a2=i;
}
else if(num==a1&&a2>i)
{
a1=num;
a2=i;
}
}

}
if(a1==-1)
printf("0\n");
else
{
printf("%d",a1);
for(i=0;i<n;i++)
{
if(a2&(1<<i))
printf(" %d",i+1);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: