您的位置:首页 > 产品设计 > UI/UE

PAT-PAT (Advanced Level) PractiseBe Unique (20) 【一星级】

2015-11-19 21:47 645 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1041

题面:


1041. Be Unique (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


题目大意:

给定一数列,求出其中第一个仅出现一次的数,没有则输出"None"。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cstring>
using namespace std;
int cnt[10010],ori[100010];
int main()
{
int n;
cin>>n;
bool flag=true;
memset(cnt,0,sizeof(cnt));
for(int i=1;i<=n;i++)
{
cin>>ori[i];
cnt[ori[i]]++;
}
for(int i=1;i<=n;i++)
{
if(cnt[ori[i]]==1)
{
cout<<ori[i]<<endl;
flag=false;
break;
}
}
if(flag)cout<<"None\n";
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: