您的位置:首页 > 其它

HDOJ 2955 Robberies 【0 1背包】

2015-11-19 19:17 369 查看

Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17563 Accepted Submission(s): 6489

[align=left]Problem Description[/align]
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only
for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

[align=left]Input[/align]
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then
follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

[align=left]Output[/align]
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

[align=left]Sample Input[/align]

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


[align=left]Sample Output[/align]

2
4
6


题目链接:HDOJ 2955 Robberies 【0 1背包】

题意: Roy想要抢劫银行,每家银行多有一定的金额和被抓到的概率,知道Roy被抓的最大概率P,

求Roy在被抓的情况下,抢劫最多。

分析: 被抓概率可以转换成安全概率,Roy 的安全概率大于 1-P 时都是安全的。

抢劫的金额为0时,肯定是安全的,所以d[0]=1;其他金额初始为最危险的所以概率全为0;

已AC代码:

#include<cstdio>
#include<cstring>
#define M 11000
#define Max(x,y) (x>y?x:y)

double dp[M],p[M],P;
int m[M],n;

int main()
{
int T,i,j,max;
scanf("%d",&T);
while(T--)
{
scanf("%lf%d",&P,&n);
max=0;//最大可抢数
for(i=0;i<n;++i)
{
scanf("%d%lf",&m[i],&p[i]);
p[i]=1-p[i];//找反面
max+=m[i];
}

memset(dp,0,sizeof(dp));
dp[0]=1.0;//抢 0 元一定不会被抓

for(i=0;i<n;++i)
for(j=max;j>=m[i];--j)
dp[j]=Max(dp[j],dp[j-m[i]]*p[i]);

for(i=max;i>=0;--i)//从大到小,找一个最大的
if(dp[i]>=1-P)
{
printf("%d\n",i);
break;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: