您的位置:首页 > 其它

hdu1325 Is It A Tree? (并查集+森林)

2015-11-19 17:58 459 查看


Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18771    Accepted Submission(s): 4189

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 

 

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 

 

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

 

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

 

Source

North Central North America 1997

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1856 1232 1233 1102 1875 

 

解析:1.0 0 输出true
           2.并查集判断所有输入数据组成一个生成树(先将边看做无向的)
           3.用ru[x]记录是否有其他点指向点x,并且保证ru[i]==0的 i 只有一个(也就是生成树的根,因为是有向边,繁殖出现这种情况:1 2 3 2 0 0)

代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ms(a) memset(a,0,sizeof(a))
using namespace std;

const int maxn=1e5;
int f[maxn+10];
bool used[maxn+10],ru[maxn+10];

int find(int x)
{
if(f[x]==x)return x;
return f[x]=find(f[x]);
}

int main()
{
freopen("1.in","r",stdin);

int x,y,rx,ry,l=maxn,r=1,s=1;
bool flag=1;ms(used),ms(ru);
while(scanf("%d%d",&x,&y),x>=0)
{
if(x==0 && y==0)
{
for(x=l,y=0;x<=r;x++)
if(used[x] && f[x]==x)y++;
flag=(flag&&y<=1);
for(x=l,y=0;x<=r;x++)
if(used[x] && !ru[x])y++;
flag=(flag&&y<=1);
if(flag)printf("Case %d is a tree.\n",s);
else printf("Case %d is not a tree.\n",s);
ms(used),ms(ru),flag=1,l=maxn,r=1,s++;
continue;
}
ru[y]=1;
if(used[x])rx=find(x);
else rx=f[x]=x,used[x]=1;
if(used[y])ry=find(y);
else ry=f[y]=y,used[y]=1;
if(rx!=ry)f[rx]=ry;else flag=0;
l=min(l,min(x,y)),r=max(r,max(x,y));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: