您的位置:首页 > 其它

sicily 1059. Exocenter of a Trian

2015-11-19 13:15 399 查看

1059. Exocenter of a Trian

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given a triangle ABC, the Extriangles of ABC are constructed as follows:

On each side of ABC, construct a square (ABDE, BCHJ and ACFG in the figure below).

Connect adjacent square corners to form the three Extriangles (AGD, BEJ and CFH in the figure).

The Exomedians of ABC are the medians of the Extriangles, which pass through vertices of the original triangle, extended into the original triangle (LAO, MBO and NCO in the figure. As the figure indicates, the three Exomedians intersect at a common point
called the Exocenter (point O in the figure).

This problem is to write a program to compute the Exocenters of triangles.



Input

The first line of the input consists of a positive integer n, which is the number of datasets that follow. Each dataset consists of 3 lines; each line contains two floating point values which represent the (two -dimensional) coordinate of one vertex of a
triangle. So, there are total of (n*3) + 1 lines of input. Note: All input triangles wi ll be strongly non-degenerate in that no vertex will be within one unit of the line through the other two vertices.

Output

For each dataset you must print out the coordinates of the Exocenter of the input triangle correct to four decimal places.

Sample Input


2
0.0 0.0
9.0 12.0
14.0 0.0
3.0 4.0
13.0 19.0
2.0 -10.0

Sample Output


9.0000 3.7500
-48.0400 23.3600


题目分析

找三角形的质心

具体证明可以见此

为了避免讨论斜率是否存在的问题,转化成向量运算

注意fabs(ans) < 0.0001输出0.0000

#include <stdio.h>
#include <math.h>

struct Point {
double x, y;
};
struct Line {
Point start, end;
};

int main() {
int test;
scanf("%d", &test);
while (test--) {
Point a, b, c;
scanf("%lf%lf%lf%lf%lf%lf", &a.x, &a.y, &b.x, &b.y, &c.x, &c.y);
Line u, v;
u.start = c;
u.end.x = u.start.x - a.y + b.y;
u.end.y = u.start.y + a.x - b.x;
v.start = b;
v.end.x = v.start.x - a.y + c.y;
v.end.y = v.start.y + a.x - c.x;

Point inter = u.start;
double t = ((u.start.x - v.start.x) * (v.start.y - v.end.y) - (u.start.y - v.start.y) * (v.start.x - v.end.x))
/ ((u.start.x - u.end.x) * (v.start.y - v.end.y) - (u.start.y - u.end.y) * (v.start.x - v.end.x));
inter.x += (u.end.x - u.start.x) * t;
inter.y += (u.end.y - u.start.y) * t;

inter.x = fabs(inter.x) < 0.0001 ? 0.0 : inter.x;
inter.y = fabs(inter.y) < 0.0001 ? 0.0 : inter.y;
printf("%.4lf %.4lf\n", inter.x, inter.y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: