您的位置:首页 > 其它

hdu 2199 Can you solve this equation?

2015-11-19 08:51 218 查看


Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13855    Accepted Submission(s): 6185


Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input

2
100
-4

 

Sample Output

1.6152
No solution!题型:二分查找注意,,double型数据不能直接用等号,而应该作使差的绝对值小于一个足够小的数,,水题#include<iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
using namespace std;
double y;
double f(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6-y;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
       scanf("%lf",&y);
       if(f(0)>0||f(100)<0)
       {
          printf("No solution!\n");
          continue;
       }
       double m,l=0,r=100;
       while(r-l>=1e-8)
       {
            m=(l+r)/2.0;
            if(f(m)<0)
               l=m;
            else
               r=m;
            if(fabs(f(m))<1e-8)
               break;
       }
       printf("%.4lf\n",m);
    }
    return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题