您的位置:首页 > 其它

hdu1701ACMer(基础)

2015-11-17 21:59 316 查看

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4336    Accepted Submission(s): 1982


[align=left]Problem Description[/align]
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number of test cases.

The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

[align=left]Output[/align]
For each test case, output the minumal number of students in HDU.
 

[align=left]Sample Input[/align]

1
13.00 14.10

 

[align=left]Sample Output[/align]

15

 题目大意:hdu的acmer最多占学校总数的Q%,最少占P%,问学校的人数最少是多少?
首先,若设最少人数为sum,则当第一个满足sum*p% < sum*Q%时的sum的值即为最小sum值。
代码如下:
#include<stdio.h>
#include<math.h>
int main()
{
int n,i;
double p,q;
scanf("%d",&n);
while(n--)
{
int sum=0;
scanf("%lf%lf",&p,&q);
int num=q-p;
i=1;
while(1)
{
if((int)(p*i/100)<(int)(q*i/100))
{
sum=i; break;
}
i++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: