您的位置:首页 > 其它

HDU 5500 Reorder the Books【水题】

2015-11-17 17:46 471 查看


Reorder the Books

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 936 Accepted Submission(s): 516



Problem Description

dxy has a collection of a series of books called "The Stories of SDOI",There are n(n≤19) books
in this series.Every book has a number from 1 to n.

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing
himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

Input

There are several testcases.

There is an positive integer T(T≤30) in
the first line standing for the number of testcases.

For each testcase, there is an positive integer n in
the first line standing for the number of books in this series.

Followed n positive
integers separated by space standing for the order of the disordered books,the ith integer
stands for the ith book's
number(from top to bottom).

Hint:

For the first testcase:Moving in the order of book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and
this is the best way to reorder the books.

For the second testcase:It's already ordered so there is no operation needed.

Output

For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

Sample Input

2
4
4 1 2 3
5
1 2 3 4 5


Sample Output

3
0
思路:给你几本编号无序的图书,问你最少调换几次才能将他们从小到大排好;调换只能把书拿到最顶部;
你只需要找到最大的编号m,标记这个位置,在最大的前面找是否存在比他小一号的书m-1,如果不存在说明最少需要调换m-1次;如果存在那就按照这个方式继续循环;
#include<stdio.h>
#include<string.h>
#define N 20
int main()
{
int T,m,i,t,j;
int arr
;
scanf("%d",&T);
while(T--)
{
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%d",&arr[i]);
t=m;
int TT=m;
while(TT--)//循环查找
{
for(i=0;i<t;i++)
{
if(arr[i]==m)
{
t=i;//更新t的值 继续循环
m--;//更新m的值
}
}
}
printf("%d\n",m);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: