您的位置:首页 > 其它

hdoj Flying to the Mars 1800 (DP)

2015-11-17 17:43 302 查看

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15114    Accepted Submission(s): 4865


[align=left]Problem Description[/align]



In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF
convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got
wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that
is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student
is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the
broomstick needed .

For example :

There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;

One method :

C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.

D could teach E;So D E are eligible to study on the same broomstick;

Using this method , we need 2 broomsticks.

Another method:

D could teach A; So A D are eligible to study on the same broomstick.

C could teach B; So B C are eligible to study on the same broomstick.

E with no teacher or student are eligible to study on one broomstick.

Using the method ,we need 3 broomsticks.

……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

[align=left]Input[/align]
Input file contains multiple test cases.

In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)

Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

[align=left]Output[/align]
For each case, output the minimum number of broomsticks on a single line.

[align=left]Sample Input[/align]

4
10
20
30
04
5
2
3
4
3
4

[align=left]Sample Output[/align]

1
2 //题意:
先输入一个n,表示有n个人,然后是n个人的技能值,技能高的可以当技能低的人的老师,
并且他们可以同坐在一个扫帚上,问最少需要几个扫帚。//Hiat:题中要求是30位的数,但其实__int64位就够了(数据的漏洞,若真想写够30位,那么就得用哈希表了,不过那个,我还不会)。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll __int64
using namespace std;
ll a[3010];
int b[3010];
int main()
{
int n,i,j;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%I64d",&a[i]);
sort(a,a+n);
memset(b,0,sizeof(b));
int mm=0;
ll tmp;
for(i=0;i<n;i++)
{
if(!b[i])
{

tmp=a[i];
b[i]=1;
for(j=i+1;j<n;j++)
{
if(!b[j]&&a[j]>tmp)
{
b[j]=1;
tmp=a[j];
}
}
mm++;
}
}
printf("%d\n",mm);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: