您的位置:首页 > 其它

矩阵连乘基础

2015-11-17 15:43 344 查看
对应题目连接:点击打开链接

Optimal Array Multiplication Sequence

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





Given two arrays A and B, we can determine the array C = AB using the standard definition of matrix multiplication:



The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let's say that rows(A) andcolumns(A) are the number
of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A) columns(B)columns(A).
For example, if A is a

array, and B is a

array,
it will take

, or 3000 multiplications to compute theC array.

To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if X, Y, and Z are arrays, then to compute XYZ we could either compute (XY) Z or X (YZ).
Suppose X is a

array, Y is a

array,
and Z is a

array. Let's look at the number of multiplications required to compute the product using
the two different sequences:

(XY) Z


multiplications to determine the product (X Y), a

array.
Then

multiplications to determine the final result.
Total multiplications: 4500.

X (YZ)


multiplications to determine the product (YZ), a

array.
Then

multiplications to determine the final result.
Total multiplications: 8750.

Clearly we'll be able to compute (XY) Z using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplications
required.

Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays
to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates
the end of the input. N will be no larger than 10.

Output

Assume the arrays are named

. Your output for each input
case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly
resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.

Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0


Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))


题意:

每组数据包含一个数 n , 接下来 n 行, 每行包含两个数,分别表示矩阵的行数和列数;求 n 个矩阵相乘的最少乘法次数,并给出方案。比如

A1:1*5 (1行5列)

A2:5*20

A3:20*1

矩阵不满足交换律但满足结合律,对于此例我们可以有 (A1 * A2) * A3 和 A1 * (A2 * A3) 两种方法,第一种所需要的乘法次数为 1 * 5 * 20 + 1 * 20 * 1 = 120 ,第二种所需要的乘法次数为 5 * 20 * 1 + 1 * 5 * 1 = 105,因此选择第二种方案的乘法次数较少,输出为(A1
* (A2 * A3))

思路:

区间 DP 的感觉

A1 A2 A3 A4 A5 A6 A7 A8

第一轮先计算 (A1 A2), (A3 A4), (A5 A6), (A7 A8) 两两之间各自需要多少次乘法

第二轮计算 (A1 A2 A3), (A2 A3 A4), (A4 A5 A6), (A6 A7 A8) 每组的 3 个数之间各自最少需要多少次乘法

...

最后计算(A1 A2 A3 A4 A5 A6 A7 A8) 连乘所需要的最少次数

计算过程用一个二维数组记录 Ai ~ Aj 之间需要分开的地方,递归打印结果。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 15
#define INF (1<<30)
int r
;
int c
;
int m

;
int v

;

void Print(int l, int r)
{
	if(l == r){
		printf("A%d", l + 1);
		return;
	}
	printf("(");
	Print(l, v[l][r]);
	printf(" x ");
	Print(v[l][r] + 1, r);
	printf(")");
}

int dp(int L, int R)
{
	if(m[L][R] != INF) return m[L][R];
	int k, tmp;
	for(k = L; k < R; k++){
		tmp = dp(L, k) + dp(k + 1, R) + r[L] * c[k] * c[R];
		if(tmp < m[L][R]){
			v[L][R] = k;
			m[L][R] = tmp;
		}
	}
	return m[L][R];
}

int main()
{
#if 0
	freopen("in.txt", "r", stdin);
#endif
	int n, w = 0;
	while(scanf("%d", &n), n){
		int i, j, k, len;
		for(i = 0; i < n; i++)
			scanf("%d%d", r + i, c + i);
		for(i = 0; i < n; i++){
			for(j = 0; j < n; j++){
				if(i != j) m[i][j] = INF; /* be careful */
				else{
					m[i][i] = 0;
					v[i][i] = i;
				}
			}
		}
		dp(0, n - 1);
		printf("Case %d: ", ++w);
		Print(0, n - 1);
		printf("\n");
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: