您的位置:首页 > 其它

DP--二维背包-- HDU - 3496

2015-11-17 14:51 381 查看
Description

New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight.
Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.

DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play
over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.

But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they
cost not more then L.

How clever you are! Please help DuoDuo’s uncle.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:

The first line is: N(N <= 100),M(M<=N),L(L <= 1000)

N: the number of DVD that DuoDuo want buy.

M: the number of DVD that the shop can sale.

L: the longest time that her grandfather allowed to watch.

The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

Output

Contain one number. (It is less then 2^31.)

The total value that DuoDuo can get tonight.

If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

Sample Input

1
32 10
11 100
1 2
9 1


Sample Output

3


分析:一维是时间, 二维是数量, 求恰好看完M部电影的最大价值(注意“恰好”对应的状态数组的初始化)

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 110;
const int maxl = 1010;
int dp[maxl][maxn], L[maxn], V[maxn];

int main()
{
int n, m, t, T;
scanf("%d", &T);
while(T--) {
scanf("%d%d%d", &n, &m, &t);
for(int i=0; i<n; i++) scanf("%d%d", &L[i], &V[i]);
for(int i=0; i<=t; i++)
for(int j=0; j<=m; j++)
if(j==0) dp[i][j] = 0;
else dp[i][j] = -INF;
for(int i=0; i<n; i++)
for(int c=t; c>=L[i]; c--)
for(int num=1; num<=m; num++)
dp[c][num] = max(dp[c][num], dp[c-L[i]][num-1] + V[i]);
printf("%d\n", dp[t][m] > 0 ? dp[t][m] : 0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: