您的位置:首页 > 其它

1058 A+B in Hogwarts

2015-11-16 22:36 267 查看
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to
compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27

Sample Output:

14.1.28

#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
//g s k 17 29
int g1 = 0,g2 = 0,s1 = 0,s2 = 0,k1 = 0,k2 = 0;
for(;scanf("%d.%d.%d %d.%d.%d",&g1,&s1,&k1,&g2,&s2,&k2)!=EOF;){
int flag = 0;
int res_k = (k1+k2)%29;
flag = (k1+k2)/29;
int res_s = (s1+s2+flag)%17;
flag = (s1+s2+flag)/17;
int res_g = g1+g2+flag;
printf("%d.%d.%d\n",res_g,res_s,res_k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: