您的位置:首页 > 其它

Yuanfang,what do you think ?

2015-11-16 11:30 363 查看

Yuanfang,what do you think ?


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

Yuanfang is the best student in the class. Every time when the teacher comes up with a hard problem and it seems no student can solve it, He always says: "Yuanfang , what do you think?".

One day, They had a math class,The teacher said:”Let’s calculate the sum of 1^2+2^2…+n^2,Yuanfang, what do you think?"

Yuanfang wanted to solve this problem quickly. So he came to you, the only programmer he knows, for help.

You should write a program to calculate SUM(n)=1^2+2^2…+n^2 to help him.

输入

There are several test cases.
Each case has an integer n (1≤n≤1000) in a line.

输出

For each test case,output one line containing a result SUM(n).

示例输入

110


示例输出

1385


提示

来源

示例程序

#include<stdio.h>
int main()
{
int i,n,m;
while(scanf("%d",&n)!=EOF)
{
m=0;
for(i=1;i<=n;i++)
{
m+=i*i;
}
printf("%d\n",m);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: