您的位置:首页 > 其它

HDOJ 5500 Reorder the Books(规律)

2015-11-15 21:59 316 查看


Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 932    Accepted Submission(s): 513


[align=left]Problem Description[/align]
dxy has a collection of a series of books called "The Stories of SDOI",There aren(n≤19)
books in this series.Every book has a number from
1
to n.

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing
himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

 

[align=left]Input[/align]
There are several testcases.

There is an positive integer T(T≤30)
in the first line standing for the number of testcases.

For each testcase, there is an positive integer n
in the first line standing for the number of books in this series.

Followed n
positive integers separated by space standing for the order of the disordered books,theith
integer stands for the ith
book's number(from top to bottom).

Hint:

For the first testcase:Moving in the order of book3,book2,book1
,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4),and
this is the best way to reorder the books.

For the second testcase:It's already ordered so there is no operation needed.
 

[align=left]Output[/align]
For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.
 

[align=left]Sample Input[/align]

2
4
4 1 2 3
5
1 2 3 4 5

 

[align=left]Sample Output[/align]

3
0

 

题意: 书的编号表示书应该在书柜中的位置,现在书柜中的书是乱的,要将书排好序。排序只能把书从原来位置放到最左边的位置上,问给出书的序列,排好序最低移动几次?

这一题半天没想出来,其实是求在数列中关于最大数的递增序列有多长len(这个序列中相邻的两个数差值为1),最
少移动次数就是n-len。

例如: 2 1 6 5 7 8 3 4       递增序列为6 7 8       最少移动次数就为  8-3

代码如下:

#include<cstdio>
int a[20];
int main()
{
int t,i,n,ans,p,len;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
len=0;p=-1;
for(i=1;i<=n;++i)
{
scanf("%d",&a[i]);
if(p<a[i]&&p+1!=a[i])
{
p=a[i];
len=1;
}
if(p<a[i]&&p+1==a[i])
{
p=a[i];
len++;
}
}
printf("%d\n",n-len);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: