您的位置:首页 > 其它

sicily 1036. Crypto Columns

2015-11-15 21:03 441 查看

1036. Crypto Columns

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The columnar encryption scheme scrambles the letters in a message (or plaintext) using a keyword as illustrated in the following example: Suppose BATBOY is the keyword and our message is MEET ME BY THE OLD OAK TREE. Since the keyword has 6 letters, we write
the message (ignoring spacing and punctuation) in a grid with 6 columns, padding with random extra letters as needed:

MEETME

BYTHEO

LDOAKT

REENTH

Here, we've padded the message with NTH. Now the message is printed out by columns, but the columns are printed in the order determined by the letters in the keyword. Since A is the letter of the keyword that comes first in the alphabet, column 2 is printed
first. The next letter, B, occurs twice. In the case of a tie like this we print the columns leftmost first, so we print column 1, then column 4. This continues, printing the remaining columns in order 5, 3 and finally 6. So, the order the columns of the grid
are printed would be 2, 1, 4, 5, 3, 6, in this case. This output is called the ciphertext, which in this example would be EYDEMBLRTHANMEKTETOEEOTH. Your job will be to recover the plaintext when given the keyword and the ciphertext.

Input

There will be multiple input sets. Each set will be 2 input lines. The first input line will hold the keyword, which will be no longer than 10 characters and will consist of all uppercase letters. The second line will be the ciphertext, which will be no
longer than 100 characters and will consist of all uppercase letters. The keyword THEEND indicates end of input, in which case there will be no ciphertext to follow.

Output

For each input set, output one line that contains the plaintext (with any characters that were added for padding). This line should contain no spacing and should be all uppercase letters.

Sample Input


BATBOY
EYDEMBLRTHANMEKTETOEEOTH
HUMDING
EIAAHEBXOIFWEHRXONNAALRSUMNREDEXCTLFTVEXPEDARTAXNAARYIEX
THEEND

Sample Output


MEETMEBYTHEOLDOAKTREENTH
ONCEUPONATIMEINALANDFARFARAWAYTHERELIVEDTHREEBEARSXXXXXX


题目分析

给定一个key,将字符串按照key的长度存成二维矩阵

按照key的每一位的字符序抽取每一列,形成密文

#include <iostream>
#include <algorithm>

struct Node {
char c;
int index;
};

bool com(Node a, Node b) {
return a.c < b.c;
}

int main()
{
std::string key;
while (std::cin >> key && key != "THEEND") {
int col = key.length();
Node nodes[col];
for (int i = 0; i < col; ++i) {
nodes[i].c = key[i];
nodes[i].index = i;
};
std::sort(nodes, nodes+col, com);
std::string line;
std::cin >> line;
int row = line.length() / col;
char ans[row][col];
int count = 0;
for (int i = 0; i < col; ++i) {
for (int j = 0; j < row; ++j) {
ans[j][nodes[i].index] = line[count++];
}
}
for (int i = 0; i < row; ++i)
for (int j = 0; j < col; ++j)
std::cout << ans[i][j];
std::cout << std::endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: