您的位置:首页 > 其它

九度oj-1041-Simple Sorting

2015-11-15 12:00 267 查看
时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:4515

解决:1688

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7


样例输出:
3 7 8


来源:2008年上海交通大学计算机研究生机试真题
#include<iostream>
#include<set>
using namespace std;
int main()
{
int n,i,t;
set<int> a;
set<int>::iterator j;
while(cin>>n)
{
a.clear();
for(i=0;i<n;i++)
{
cin>>t;
a.insert(t);
}
j=a.begin();
t=a.size();
for(i=0;i<t-1;i++,j++)
cout<<*j<<" ";
cout<<*j<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  九度