您的位置:首页 > Web前端

Poj.1730 Perfect Pth Powers【数学】 2015/11/13

2015-11-13 20:11 375 查看
Perfect Pth Powers

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 17232Accepted: 3946
Description

We say that x is a perfect square if, for some integer b, x = b2. Similarly, x is a perfect cube if, for some integer b, x = b3. More generally, x is a perfect pth power if, for some integer b, x = bp. Given an integer x you
are to determine the largest p such that x is a perfect pth power.
Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.
Output

For each test case, output a line giving the largest integer p such that x is a perfect pth power.
Sample Input
17
1073741824
25
0

Sample Output
1
30
2

Source

Waterloo local 2004.01.31

不明所以,为何要加0.1???

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#define eps 1e-6

using namespace std;

int main(){
int n,t,p;
while( ~scanf("%d",&n) ){
if( n == 1 || n == -1 ) continue;
if( n == 0 ) break;
if( n > 0 ){
for( int i = 31 ; i >= 1 ; --i ){
t = (int)(pow(1.0*n,1.0/i)+0.1);
p = (int)(pow(1.0*t,1.0*i)+0.1);
if( n == p ){
printf("%d\n",i);
break;
}
}
}
else{
n = -n;
for( int i = 31 ; i >= 1 ; i-=2 ){
t = (int)(pow(1.0*n,1.0/i)+0.1);
p = (int)(pow(1.0*t,1.0*i)+0.1);
if( n == p ){
printf("%d\n",i);
break;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: