您的位置:首页 > 其它

HDOJ 1528 Card Game Cheater (模拟田忌赛马贪心)

2015-11-13 19:22 344 查看

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1575    Accepted Submission(s): 829


[align=left]Problem Description[/align]
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards
face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for
each i ∈ {1, . . . , k}):

If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders
her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

 

[align=left]Input[/align]
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has
not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are
the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

 

[align=left]Output[/align]
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

[align=left]Sample Input[/align]

3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D

 

[align=left]Sample Output[/align]

1
1
2

 

题意:两个人拿牌,有一定的大小规则,王牌最大,红桃(H)>黑桃(S)>方块(D)>梅花(C),给你n张牌,求Eve最多能赢几次,第二行的是Eve的牌

思路:就是一个田忌赛马的模拟,只不过判断的是你两个方面,直接按照田忌赛马的贪心写就行了,想了解田忌赛马的点击链接:点击打开链接

ac代码:

#include<stdio.h>
#include<math.h>
#include<queue>
#include<iostream>
#include<algorithm>
#define MAXN 1010
#define MOD 10000
#define LL long long
#define INF 0xfffffff
#define fab(a)(a)>0?(a):(-a)
using namespace std;
struct s
{
int num;
int kind;
}a[MAXN],b[MAXN];
char str[5];
int find1(char x)
{
if(x=='A')
return INF;
else if(x=='T')
return 10;
else if(x=='J')
return 11;
else if(x=='Q')
return 12;
else if(x=='K')
return 13;
else
return x-'0';
}
int find2(char x)
{
if(x=='H')
return 1;
else if(x=='S')
return 2;
else if(x=='D')
return 3;
else
return 4;
}
bool cmp(s aa,s bb)
{
if(aa.num==bb.num)
return aa.kind>bb.kind;
return aa.num<bb.num;
}
int main()
{
int t,i,n,j;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s",str);
a[i].num=find1(str[0]);//确定牌的大小和花色
a[i].kind=find2(str[1]);
}
for(i=0;i<n;i++)
{
scanf("%s",str);
b[i].num=find1(str[0]);
b[i].kind=find2(str[1]);
}
sort(a,a+n,cmp);
sort(b,b+n,cmp);
//    for(i=0;i<n;i++)
//    printf("%d %d\n",a[i].num,a[i].kind);
int num=0;
int al=0,ah=n-1;
int bl=0,bh=n-1;
while(bl<=bh)
{
if(b[bh].num>a[ah].num||(b[bh].num==a[ah].num&&b[bh].kind<a[ah].kind))
{
ah--;
bh--;
num++;
}
else if(b[bl].num>a[al].num||(b[bl].num==a[al].num&&b[bl].kind<a[al].kind))
{
al++;
bl++;
num++;
}
else if(a[ah].num<b[bl].num||(a[ah].num==b[bl].num&&a[ah].kind>b[bl].kind))
{
num--;
bl++;
ah--;
}
else
{
bl++;
ah--;
}
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: