您的位置:首页 > 其它

杭电5533 Dancing Stars on Me

2015-11-13 14:16 176 查看


Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 360    Accepted Submission(s): 217


Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera.
Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon.
To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

 

Input

The first line contains a integer T indicating
the total number of test cases. Each test case begins with an integer n,
denoting the number of stars in the sky. Following n lines,
each contains 2 integers xi,yi,
describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000

All coordinates are distinct.

 

Output

For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).

 

Sample Input

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

 

Sample Output

NO
YES
NO

 

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  5551 5550 5549 5548 5547 

 

算是水题吧,不用求凸包,直接就能算出来:

#include<stdio.h>
int i,j,k,l,m,n,ans;
double a[1100],b[1100],Min;
int ac(int i,int j)
{
return ((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
}
int main()
{
scanf("%d",&k);
while(k--)
{
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%lf%lf",&a[i],&b[i]);
Min=0x3f3f3f3f*1.0;//定义为无穷大
for(i=0;i<m;i++)
for(j=i+1;j<m;j++)
Min=Min<ac(i,j)?Min:ac(i,j);//找到最小的边
ans=0;
for(i=0;i<m;i++)
for(j=i+1;j<m;j++)
if(ac(i,j)==Min)//最小边的个数为M
ans++;
if(ans==m)
printf("YES\n");
else
printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 数学