您的位置:首页 > 运维架构

HDU 1011.Starship Troopers【树上DP】【11月13】

2015-11-13 13:51 459 查看
Starship Troopers

Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output

50
7


本身DP就不好想,这个题是在树上进行DP。

题意:

带领m个士兵,存在n个房间;每个房间有两个参数:放置的bugs数以及存在头领的可能性。

每个士兵可以抵抗20个bugs,只有消灭房间中的所有bugs,才可以得到该房间的头领的可能性。

有指定的房间与房间之间的联通性,要到达下一个房间,必须先将当前房间的bugs全部消除;并且走过的房间就不再到达。

问有m个士兵的情况下,怎样使最后得到的头领的可能性最大,最大为多少?

DP[i][j]=max(DP[i][j],DP[i][j-k]+DP[son(i)][k])

DP[i][j]表示第i个房间以及其子节点花费j个士兵可以得到的最大可能值

代码如下:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
const int MAXN = 105;
int val[MAXN], node[MAXN][MAXN], bug[MAXN], DP[MAXN][MAXN];
int N, M;
bool key;
void dfs(int nownode, int prenode)
{
for(int i = bug[nownode]; i <= M; i ++) DP[nownode][i] = val[nownode];
for(int i = 1; i <= N; i ++)
{
if(node[nownode][i] && i != prenode)
{
dfs(i,nownode);
for(int j = M; j >= bug[nownode]; j--)
for(int k = 1; k <= j - bug[nownode]; k ++)
DP[nownode][j] = max(DP[nownode][j], DP[nownode][j - k] + DP[i][k]);
}
}
}
int main()
{
while(scanf("%d%d", &N, &M) == 2 && N != -1)
{
int node1, node2;
memset(DP, 0, sizeof(DP));
memset(node, 0, sizeof(node));
for(int i = 1; i <= N; i ++)
{
scanf("%d %d", &bug[i], &val[i]);
bug[i] = (bug[i] + 19) / 20;//转换成需要的士兵数
}

for(int i = 1; i < N; i ++)
{
scanf("%d %d", &node1, &node2);
node[node1][node2] = 1;
node[node2][node1] = 1;
}
if(!M)//不解释
{
printf("0\n");
continue;
}
dfs(1,-1);
printf("%d\n", DP[1][M]);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: