您的位置:首页 > 其它

HDU 4722 数位DP

2015-11-10 00:00 288 查看

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3620    Accepted Submission(s): 1147


[align=left]Problem Description[/align]
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.

You are required to count the number of good numbers in the range from A to B, inclusive.
 

[align=left]Input[/align]
The first line has a number T (T <= 10000) , indicating the number of test cases.

Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
 

[align=left]Output[/align]
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

[align=left]Sample Input[/align]

2
1 10
1 20

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 1
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=22;
__int64 dp[MAX][10];//分别代表长度为i位数和mod 10为j的个数 
int digit[MAX];

void digit_dp(){//计算每长度为i为的数mod 10 == 0的个数 
dp[0][0]=1;
for(int i=1;i<MAX;++i){
for(int j=0;j<10;++j){
for(int k=0;k<10;++k){
dp[i][j]+=dp[i-1][(j-k+10)%10];
}
}
}
}

__int64 calculate(__int64 n){
int size=0,last=0;
__int64 sum=0;
while(n)digit[++size]=n%10,n/=10;
for(int i=size;i>=1;--i){
for(int j=0;j<digit[i];++j){
sum+=dp[i-1][((j+last)%10+10)%10];
}
last=(last+digit[i])%10;
}
return sum;
}

int main(){
digit_dp();
int t,num=0;
__int64 a,b;
scanf("%d",&t);
while(t--){
scanf("%I64d%I64d",&a,&b);
printf("Case #%d: %I64d\n",++num,calculate(b+1)-calculate(a));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: