您的位置:首页 > 其它

Sum Problem

2015-11-09 10:34 239 查看


Sum Problem



Time Limit: 500ms Memory limit: 32768K 有疑问?点这里^_^


题目描述

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

输入

The input will consist of a series of integers n, one integer per line.

输出

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

示例输入

1
100


示例输出

1

5050


来源

sdut

#include<stdio.h>
int main()
{
int i=1,sum=0,n;
while(scanf("%d",&n)!=EOF)
{
while(i<=n)
{
sum+=i;
i++;
}
printf("%d\n\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: