您的位置:首页 > 其它

HDOJ 5240 Exam 【sort排序&&模拟】

2015-11-08 19:14 281 查看

Exam

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1040 Accepted Submission(s): 520

[align=left]Problem Description[/align]
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n


exams. They are all hard, but their difficulties are different. DRD will spend at least
r

i




hours on the i

-th
course before its exam starts, or he will fail it. The
i

-th
course's exam will take place e

i




hours later from now, and it will last for l

i




hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.

[align=left]Input[/align]
First line: an positive integer
T≤20


indicating the number of test cases.

There are T cases following. In each case, the first line contains an positive integer
n≤10

5



,
and n


lines follow. In each of these lines, there are 3 integers
r

i

,e

i

,l

i



,
where 0≤r

i

,e

i

,l

i

≤10

9



.

[align=left]Output[/align]
For each test case: output ''Case #x: ans'' (without quotes), where
x


is the number of test cases, and ans


is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

[align=left]Sample Input[/align]

2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2


[align=left]Sample Output[/align]

Case #1: NO
Case #2: YES


[align=left]Source[/align]
The 2015 ACM-ICPC China Shanghai Metropolitan Programming Contest

思路:

对开始考试的时间进行排序(按照从小到大的顺序),然后用这次考试的开始时间减去上次考试的开始时间,然后再减去上次考试占用的时间,和上次考试前复习的时间,再减去这次考试前需要复习占用的时间,再加上上次(到上次考试结束)没有用完的时间;如果这个值小于0,那么就输出NO,跳出循环,如果都满足大于等于0,就输出YES!

代码如下:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n;
struct node
{
int t_1,t_2,t_3;
}a[100005];
int cmp(node a,node b)
{
return a.t_2<b.t_2;
}
int main()
{
int T;
scanf("%d",&T);
int N=T;
while(T--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&a[i].t_1,&a[i].t_2,&a[i].t_3);
}
sort(a+1,a+n+1,cmp);
int t=0;
printf("Case #%d: ",N-T);
int i;
for(i=1;i<=n;i++)
{
t=a[i].t_2-(a[i-1].t_2+a[i-1].t_3)+t-a[i].t_1;//
if(t<0)
{
printf("NO\n");
break;
}
}
if(i==n+1)
{
printf("YES\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: