您的位置:首页 > 其它

Hdu 5240 Exam【贪心】

2015-11-08 13:24 330 查看
Description

As this term is going to end, DRD needs to prepare for his final exams. 

DRD has n exams.
They are all hard, but their difficulties are different. DRD will spend at least ri hours
on the i-th
course before its exam starts, or he will fail it. The i-th
course's exam will take place ei hours
later from now, and it will last for li hours.
When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 

 

Input

First line: an positive integer T≤20 indicating
the number of test cases. 

There are T cases following. In each case, the first line contains an positive integer n≤105,
and n lines
follow. In each of these lines, there are 3 integers ri,ei,li,
where 0≤ri,ei,li≤109. 

 

Output

For each test case: output ''Case #x: ans'' (without quotes), where x is
the number of test cases, and ans is
''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

Sample Input

2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2

 

Sample Output

Case #1: NO
Case #2: YES

 

给出若干门课的通过需要复习的时间,考试开始时间和考试持续时间,求这个人能否参加和通过所有考试,贪心排序,看是否有重合的区间.......

水掉..

#include<stdio.h>
#include<algorithm>
using namespace std;
int n;
struct work
{
int r,e,l;
}x[100005];

int cmp(work a,work b)
{
if(a.e==b.e)
{
return a.r<b.r;
}
return a.e<b.e;
}

int judge()
{
int time=0;
for(int i=0;i<n;++i)
{
if(x[i].r+time<=x[i].e)//可以通过
{
time=x[i].e+x[i].l;//考完试了
}
else
{
return 0;
}
}
return 1;
}

int main()
{
int t;
//freopen("shuju.txt","r",stdin);
scanf("%d",&t);
for(int k=1;k<=t;++k)
{
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%d%d%d",&x[i].r,&x[i].e,&x[i].l);
}
sort(x,x+n,cmp);
if(judge())
{
printf("Case #%d: YES\n",k);
}
else
{
printf("Case #%d: NO\n",k);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: