您的位置:首页 > 其它

HDU 4046

2015-11-07 23:33 225 查看


Panda

Time Limit: 10000/4000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2950 Accepted Submission(s): 983



Problem Description

When I wrote down this letter, you may have been on the airplane to U.S.

We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror.
I love your smile and your shining eyes. When you are with me, every second is wonderful.

The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way
is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.

I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.

There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.

Saerdna.

It comes back to several years ago. I still remember your immature face.

The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you
are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.

Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.

The love letter is too long and Panda has not that much time to see the whole letter.

But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.

But Panda doesn't know how many Saerdna's love there are in the letter.

Can you help Panda?



Input

An integer T means the number of test cases T<=100

For each test case:

First line is two integers n, m

n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000

The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.

The next m lines

Each line has two type

Type 0: answer how many love between L and R. (0<=L<=R<n)

Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)



Output

For each test case, output the case number first.

The answer of the question.



Sample Input

2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4




Sample Output

Case 1: 
1 
1 
Case 2: 
2 
1 
1 
0




Source

The 36th ACM/ICPC Asia Regional
Beijing Site —— Online Contest



Recommend

#include <cstdio>
#include <vector>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;
#define N 50000 + 10

int sum
, n, m;
char s
;

void update(int x, int val)
{
    while(x < N)
    {
        sum[x] += val;
        x += x & (-x);
    }
}

int get_sum(int x)
{
    int ret = 0;
    while(x > 0)
    {
        ret += sum[x];
        x -= x & (-x);
    }
    return ret;
}

bool judge(int i)
{
    if(s[i - 1] == 'w' && s[i] == 'b' && s[i + 1] == 'w') return true;
    else return false;
}

void doit(int i)
{
    if(i - 1 < 1 || i + 1 > n) return ;
    else
    {
        if(get_sum(i) - get_sum(i - 1) == 1) update(i, -1);
        update(i, judge(i));
    }
}

int main()
{
    int _T;
    int kase = 0;
    scanf("%d", &_T);
    while(_T--)
    {
        printf("Case %d:\n", ++kase);
        scanf("%d%d", &n, &m);
        scanf("%s", s + 1);
        int len = strlen(s + 1);
        memset(sum, 0, sizeof sum);
        for(int i = 2; i < len; i++)
            if(judge(i))
                update(i, 1);

        int op, L, R;
        char ch;
        while(m--)
        {
            scanf("%d", &op);
            if(op == 1)
            {
                scanf("%d %c", &L, &ch);
                L++;
                if(s[L] != ch)
                    {
                        s[L] = ch;
                        doit(L - 1); doit(L); doit(L + 1);
                    }
            }
            else
            {
                scanf("%d%d", &L, &R);
                if(R - L < 2) printf("0\n");
                else
                {
                    L++, R++;
                    printf("%d\n", get_sum(R - 1) - get_sum(L));
                }
            }
        }
    }
    return 0;
}

/*

1
7 4
wbwbwbw
0 1 5

100
10 10
bbbbbwwwww
0 0 9
1 1 w
0 0 2
1 3 w
0 0 5
0 0 9
1 6 b
0 0 9
1 8 b
0 0 9

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: