您的位置:首页 > 其它

The 2015 China Collegiate Programming Contest A - Secrete Master Plan

2015-11-07 21:50 549 查看


Secrete Master Plan

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 138    Accepted Submission(s): 101


Problem Description

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on
a piece of sheet. The numbers form 2×2 matrix,
but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.



 

Input

The first line of the input gives the number of test cases, T(1≤T≤104). T test
cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 (1≤ai0,ai1≤100).
The first two lines stands for the original plan, the 3rd and 4th line
stands for the plan Fei opened.

 

Output

For each test case, output one line containing "Case #x: y", where x is the test case number

(starting from 1) and y is
either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).

 

Sample Input

4
1 2
3 4
1 2
3 4

1 2
3 4
3 1
4 2

1 2
3 4
3 2
4 1

1 2
3 4
4 3
2 1

 

Sample Output

Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE

 

题目大意:

     给你个两个二阶矩阵,问是否能通过旋转相等;

解题思路:

    水题,模拟;

代码:

#include <iostream>
#include <stdlib.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <vector>
#include <sstream>
using namespace std;
int map[5][5];
int num[5][5];
int main()
{
int t,n;
int cas=0;
scanf("%d",&t);
while(t--)
{
bool flag=false;
scanf("%d%d%d%d",&map[1][1],&map[1][2],&map[2][1],&map[2][2]);
scanf("%d%d%d%d",&num[1][1],&num[1][2],&num[2][1],&num[2][2]);
if(num[1][1]==map[1][1]&&num[1][2]==map[1][2]&&num[2][1]==map[2][1]&&num[2][2]==map[2][2])
flag=true;
else if(num[1][1]==map[2][1]&&num[1][2]==map[1][1]&&num[2][1]==map[2][2]&&num[2][2]==map[1][2])
flag=true;
else if(num[1][1]==map[2][2]&&num[1][2]==map[2][1]&&num[2][1]==map[1][2]&&num[2][2]==map[1][1])
flag=true;
else if(num[1][1]==map[1][2]&&num[1][2]==map[2][2]&&num[2][1]==map[1][1]&&num[2][2]==map[2][1])
flag=true;
if(flag)
printf("Case #%d: POSSIBLE\n",++cas);
else
printf("Case #%d: IMPOSSIBLE\n",++cas);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  The 2015 China Colle