您的位置:首页 > 其它

Light Bulb

2015-11-06 21:27 309 查看
Light Bulb

Time Limit: 1 Second
Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found
that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.



Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb whileh is the height of mildleopard.D is distance between the light bulb and the wall. All numbers are
in range from 10-2 to 103, both inclusive, andH -h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4


Sample Output

1.000
0.750
4.000

#include<iostream>
#include<stdio.h>
using namespace std;
double D,H,h;
double cha(double x){
return D-x+H-(H-h)*D/x;
}
double Sansearch(double left,double right){
double mid,midmid;
while(right-left>=1e-9)
{
mid=(left+right)/2;
midmid=(mid+right)/2;
if(cha(mid)>=cha(midmid))
right=midmid;
else left=mid;
}
return mid;
}
int main()
{
int T;
double l,r;
cin>>T;
while(T--)
{
cin>>H>>h>>D;
l=(H-h)*D/H;r=D;
printf("%.3lf\n",cha(Sansearch(l,r)));
}
return 0;
}


[/code]

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: