您的位置:首页 > 其它

hdu 2844 Coins(多重背包)

2015-11-06 16:52 375 查看
http://acm.hdu.edu.cn/showproblem.php?pid=2844


Coins

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the
price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed
by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

 题目意思是求出硬币的组合方案,使得硬币的总价值不超过价值m。

         DP问题,可以转换成求多重背包的方案数目。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 140000
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

typedef long long LL;

int dp
;
char vis
;

int main ()
{
int n, m, v
, c
;
while (scanf ("%d %d", &n, &m), n+m)
{
int cnt = 0;
for (int i=1; i<=n; i++)
scanf ("%d", &v[i]);

for (int j=1; j<=n; j++)
scanf ("%d", &c[j]);

met (vis, 0);
vis[0] = true;

for (int i=1; i<=n; i++)
{
met (dp, 0);
for (int j=v[i]; j<=m; j++)
{
if (!vis[j] && vis[j-v[i]] && dp[j-v[i]] < c[i])
{
vis[j] = true;//记录当前这个价值是否出现过
dp[j] = dp[j-v[i]] + 1;//记录用金币的数量
cnt++;
}
}
}
printf ("%d\n", cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: