您的位置:首页 > 其它

hdoj 1331 Function Run Fun

2015-11-05 21:01 387 查看

Function Run Fun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3096    Accepted Submission(s): 1490


[align=left]Problem Description[/align]
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:

1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:

w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

 

[align=left]Input[/align]
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

 

[align=left]Output[/align]
Print the value for w(a,b,c) for each triple.
 

[align=left]Sample Input[/align]

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

 

[align=left]Sample Output[/align]

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1记忆化搜索,记忆每个状态的值,搜索!
#include<stdio.h>
#include<string.h>
#define N 30
int count

;
int dfs(int  a,int b,int c)
{
if(a<=0||b<=0||c<=0)
return  1;
if(a>20||b>20||c>20)
return dfs(20,20,20);
if(count[a][b][c])
return count[a][b][c];
if(a<b&&b<c)
return  count[a][b][c]=dfs(a,b,c-1)+dfs(a,b-1,c-1)-dfs(a,b-1,c);
return count[a][b][c]=dfs(a-1,b,c)+dfs(a-1,b-1,c)+dfs(a-1,b,c-1)-dfs(a-1,b-1,c-1);
}
int main()
{
int  a,b,c;
while(scanf("%d%d%d",&a,&b,&c)!=EOF&&(a!=-1||b!=-1||c!=-1))
{
memset(count,0,sizeof(count));
int counts=dfs(a,b,c);
printf("w(%d, %d, %d) = %d\n",a,b,c,counts);
}
return  0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息