您的位置:首页 > 其它

UVA11488——Hyper Prefix Sets(字典树,最长前缀)

2015-11-05 19:48 483 查看
Prefix goodness of a set string is length of longest common prefix*number of strings in the set. For

example the prefix goodness of the set {000,001,0011} is 6.You are given a set of binary strings. Find

the maximum prefix goodness among all possible subsets of these binary strings.

Input

First line of the input contains T (≤ 20) the number of test cases. Each of the test cases start with n

(≤ 50000) the number of strings. Each of the next n lines contains a string containing only ‘0’ and ‘1’.

Maximum length of each of these string is 200.

Output

For each test case output the maximum prefix goodness among all possible subsets of n binary strings.

Sample Input

4

4

0000

0001

10101

010

2

01010010101010101010

11010010101010101010

3

010101010101000010001010

010101010101000010001000

010101010101000010001010

5

01010101010100001010010010100101

01010101010100001010011010101010

00001010101010110101

0001010101011010101

00010101010101001

Sample Output

6

20

66

44

求最长公共前缀,第一个例子中,最长公共前缀是000,有两个这样的序列,所以是3*2=6

第二个例子中,最长公共前缀是0,所以可以把自己本身作为前缀,前缀的长度就是自己本身的长度,所以是20*1=20

用结构体数组实现字典树,child[0]表示该点之后有个0,里面存放的是这个0的位置

#include <iostream>
#include <cstring>
#include <cstdio>
#define N 50010
#define M 210
using namespace std;
struct trie
{
int child[2],shownum;
void init()
{
shownum=0;
memset(child,-1,sizeof(child));
}
};
int n,nn,ant;
char str
[M];
trie tr[10*N];
void init()
{
for(int i=0;i<10*N;++i)
tr[i].init();
}
void inset(char s[])
{
int x=0,sn=strlen(s),num;
for(int i=0;i<sn;++i)
{
num=s[i]-'0';
if(tr[x].child[num]==-1)
tr[x].child[num]=++nn;
x=tr[x].child[num];
tr[x].shownum++;
ant=max(ant,(i+1)*tr[x].shownum);
}
}
void read()
{
for(int i=0;i<n;++i)
{
scanf("%s",str[i]);
inset(str[i]);
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
nn=0;
ant=0;
init();
read();
printf("%d\n",ant);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: