您的位置:首页 > 其它

hdoj Dancing Stars on Me 5533 (数学几何&&技巧)

2015-11-05 13:23 204 查看

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 204 Accepted Submission(s): 138


[align=left]Problem Description[/align]
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these
moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon.
To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

[align=left]Input[/align]
The first line contains a integer
T
indicating the total number of test cases. Each test case begins with an integer
n,
denoting the number of stars in the sky. Following
n
lines, each contains 2
integers xi,yi,
describe the coordinates of n
stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000

All coordinates are distinct.

[align=left]Output[/align]
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).

[align=left]Sample Input[/align]

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

[align=left]Sample Output[/align]

NO
YES
NO//题意:给n个点,问是否可以组成正n边形。//思路:若能组成,则有n条边是相等的,并且这n条边是最小的
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int b[3100];
int map[310][310];
struct zz
{
int x;
int y;
}a[310];
int main()
{
int t,n,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&a[i].x,&a[i].y);
int k=0;
int mm=INF;
memset(map,0,sizeof(map));
for(i=0;i<n-1;i++)
{
for(j=i+1;j<n;j++)
{
if(map[i][j]||map[j][i])//消除重边
continue;
b[k]=(a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y);
mm=min(mm,b[k]);
k++;
map[i][j]=1;
}
}
int num=0;
for(i=0;i<k;i++)
if(b[i]==mm)
num++;
if(num==n)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: