您的位置:首页 > 其它

最小循环节len-next[len]

2015-11-04 19:53 239 查看
A B C D E F G H I J K

A - The Minimum Length
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu
Submit Status

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the
shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde


Sample Output

3
7

#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;
char t[1000001];
int next[1000001];
int main()
{

while(scanf("%s",t)!=EOF)
{
int len=strlen(t);
int i=0,j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||t[i]==t[j])
{
i++;
j++;
if(t[i]!=t[j])
next[i]=j;
else
next[i]=next[j];
}
else
j=next[j];
}
printf("%d\n",len-next[len]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: